在 Ubuntu 14.04 (及以上)中快速安装 Vim 神器代码补全引擎 YouCompleteMe

已经有太多关于最近非常流行的Vim代码补全引擎YouCompleteMe的介绍了。该自动补全引擎不再是之前那种死板的ctags方式,而是基于语义的(如果不知道什么是基于语义的也没关系,只要知道它的准确度非常高就行了),所以之前那些超级难用的 ctags/cscope/taglist 什么的都完全可以仍了,我没有开玩笑。

YouCompleteMe官方提供的安装教程太过复杂。不太符合 Ubuntu 软件安装的一贯作风 --- 一个apt-get即可。

然后,不知道什么时候,YouCompleteMe 已经出现在 Ubuntu 的软件源中了,所以,如果你用的是 Ubuntu 14.04 或以上版本,就可以像下面这样安装(该 sudo 的请手动加上):

$ apt-get install vim
$ apt-get install vim-youcompleteme
$ apt-get install vim-addon-manager
$ vam install youcompleteme
Info: installing removed addon 'youcompleteme' to /home/twofei/.vim
Info: Rebuilding tags since documentation has been modified ...
Processing /home/twofei/.vim/doc/
Info: done.

到这里, YCM 就已经成功安装了。

这只是一个快速安装过程,可能安装的版本不是最新,喜欢折腾的请手动编译安装!

外部链接

发表于:2015年07月29日 ,阅读量:1212 ,标签:vim · Ubuntu

版权声明:若非特别注明,本站所有文章均为作者原创,转载请务必注明原文地址。